Mon, 09 Nov 2026 08:04:11 UTC Log in
Python library for internationalized usernames and passwords 53.20 KB built 2026-10-17 12:02:53 GMT

Description

If you want your application to accept Unicode user names and passwords, you must be careful in how you validate and compare them. The PRECIS framework makes internationalized user names and passwords safer for use by applications. PRECIS profiles transform Unicode strings into a canonical form, suitable for comparison. This Python module implements the PRECIS Framework as described in: PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols (RFC 8264) Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords (RFC 8265) Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames (RFC 8266)

Dependencies

11 total
Requires6
  • python(abi) = 3.15
  • rpmlib(CompressedFileNames) <= 3.0.4-1
  • rpmlib(FileDigests) <= 4.6.0-1
  • rpmlib(PartialHardlinkSets) <= 4.0.4-1
  • rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  • rpmlib(PayloadIsZstd) <= 5.4.18-1
Provides5
  • python-precis_i18n = 1.1.2-2.fc45
  • python3-precis_i18n = 1.1.2-2.fc45
  • python3.15-precis_i18n = 1.1.2-2.fc45
  • python3.15dist(precis-i18n) = 1.1.2
  • python3dist(precis-i18n) = 1.1.2
ObsoletesNo Obsoletes
ConflictsNo Conflicts
RecommendsNo Recommends
SuggestsNo Suggests
SupplementsNo Supplements
EnhancesNo Enhances

Files

54
Name ascending sort Size
/usr/lib/python3.15/site-packages/precis_i18n 0.00 B
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info 0.00 B
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/INSTALLER 4.00 B
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/METADATA 10.83 KB
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/WHEEL 91.00 B
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/licenses 0.00 B
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/licenses/LICENSE.txt 1.04 KB
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/top_level.txt 12.00 B
/usr/lib/python3.15/site-packages/precis_i18n-1.1.2.dist-info/zip-safe 1.00 B
/usr/lib/python3.15/site-packages/precis_i18n/__init__.py 159.00 B
/usr/lib/python3.15/site-packages/precis_i18n/__init__.pyi 77.00 B
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__ 0.00 B
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/__init__.cpython-315.opt-1.pyc 312.00 B
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/__init__.cpython-315.pyc 312.00 B
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/baseclass.cpython-315.opt-1.pyc 3.76 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/baseclass.cpython-315.pyc 3.76 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/bidi.cpython-315.opt-1.pyc 4.12 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/bidi.cpython-315.pyc 4.26 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/codec.cpython-315.opt-1.pyc 1.57 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/codec.cpython-315.pyc 1.57 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/codepointset.cpython-315.opt-1.pyc 7.33 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/codepointset.cpython-315.pyc 7.44 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/context.cpython-315.opt-1.pyc 7.83 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/context.cpython-315.pyc 8.33 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/derived.cpython-315.opt-1.pyc 8.98 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/derived.cpython-315.pyc 8.98 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/factory.cpython-315.opt-1.pyc 3.32 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/factory.cpython-315.pyc 3.32 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/profile.cpython-315.opt-1.pyc 10.96 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/profile.cpython-315.pyc 10.96 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/unicode.cpython-315.opt-1.pyc 13.86 KB
/usr/lib/python3.15/site-packages/precis_i18n/__pycache__/unicode.cpython-315.pyc 14.54 KB
/usr/lib/python3.15/site-packages/precis_i18n/baseclass.py 2.92 KB
/usr/lib/python3.15/site-packages/precis_i18n/baseclass.pyi 503.00 B
/usr/lib/python3.15/site-packages/precis_i18n/bidi.py 3.58 KB
/usr/lib/python3.15/site-packages/precis_i18n/bidi.pyi 378.00 B
/usr/lib/python3.15/site-packages/precis_i18n/codec.py 894.00 B
/usr/lib/python3.15/site-packages/precis_i18n/codec.pyi 108.00 B
/usr/lib/python3.15/site-packages/precis_i18n/codepointset.py 4.82 KB
/usr/lib/python3.15/site-packages/precis_i18n/codepointset.pyi 337.00 B
/usr/lib/python3.15/site-packages/precis_i18n/context.py 7.07 KB
/usr/lib/python3.15/site-packages/precis_i18n/context.pyi 794.00 B
/usr/lib/python3.15/site-packages/precis_i18n/derived.py 9.38 KB
/usr/lib/python3.15/site-packages/precis_i18n/derived.pyi 1.09 KB
/usr/lib/python3.15/site-packages/precis_i18n/factory.py 2.75 KB
/usr/lib/python3.15/site-packages/precis_i18n/factory.pyi 289.00 B
/usr/lib/python3.15/site-packages/precis_i18n/profile.py 8.59 KB
/usr/lib/python3.15/site-packages/precis_i18n/profile.pyi 1.49 KB
/usr/lib/python3.15/site-packages/precis_i18n/py.typed 0.00 B
/usr/lib/python3.15/site-packages/precis_i18n/unicode.py 11.90 KB
Files 1–50 of 54 Next →
of 2

Component of

buildroots that installed this RPM

No Buildroots