Python library for internationalized usernames and passwords
299.98 KB
built 2026-10-17 12:02:53 GMT
Description
If you want your application to accept Unicode user names and passwords, you
must be careful in how you validate and compare them. The PRECIS framework
makes internationalized user names and passwords safer for use by applications.
PRECIS profiles transform Unicode strings into a canonical form, suitable for
comparison.
This Python module implements the PRECIS Framework as described in:
PRECIS Framework: Preparation, Enforcement, and Comparison of
Internationalized Strings in Application Protocols (RFC 8264)
Preparation, Enforcement, and Comparison of Internationalized Strings
Representing Usernames and Passwords (RFC 8265)
Preparation, Enforcement, and Comparison of Internationalized Strings
Representing Nicknames (RFC 8266)
Dependencies
11 totalRequires10
- pyproject-rpm-macros
- python3-devel
- python3-devel
- python3-pytest
- python3dist(packaging)
- python3dist(pip) >= 19
- python3dist(setuptools) >= 40.8
- rpmlib(CompressedFileNames) <= 3.0.4-1
- rpmlib(DynamicBuildRequires) <= 4.15.0-1
- rpmlib(FileDigests) <= 4.6.0-1
Provides1
- python3-precis_i18n = 1.1.2-2.fc45
ObsoletesNo Obsoletes
ConflictsNo Conflicts
RecommendsNo Recommends
SuggestsNo Suggests
SupplementsNo Supplements
EnhancesNo Enhances
Files
2Name ![]() |
Size |
|---|---|
| precis_i18n-1.1.2.tar.gz | 281.36 KB |
| python-precis_i18n.spec | 6.28 KB |
Files 1–2 of 2
Component of
buildroots that installed this RPMNo Buildroots
