Wed, 11 Nov 2026 02:40:08 UTC Log in
DNSSEC modules for Perl 60.82 KB built 2026-10-16 22:42:56 GMT

Description

Net::DNS::SEC is installed as an extension to an existing Net::DNS installation providing packages to support DNSSEC as specified in RFC4033, RFC4034, RFC4035 and related documents. It also provides support for SIG0 which is useful for dynamic updates. It implements cryptographic signature generation and verification functions using RSA, DSA, ECDSA, and Edwards curve algorithms.

Dependencies

41 total
Requires27
  • ld-linux-riscv64-lp64d.so.1()(64bit)
  • ld-linux-riscv64-lp64d.so.1(GLIBC_2.27)(64bit)
  • libc.so.6()(64bit)
  • libc.so.6(GLIBC_2.27)(64bit)
  • libcrypto.so.4()(64bit)
  • libcrypto.so.4(OPENSSL_4.0.0)(64bit)
  • libperl.so.5.42()(64bit)
  • perl(:MODULE_COMPAT_5.42.1)
  • perl(Carp) >= 1.1
  • perl(DynaLoader) >= 1.09
  • perl(Exporter) >= 5.63
  • perl(File::Spec) >= 3.29
  • perl(IO::File) >= 1.14
  • perl(MIME::Base64) >= 3.07
  • perl(Net::DNS) >= 1.08
  • perl(Net::DNS::ZoneFile)
  • perl(base)
  • perl(constant)
  • perl(integer)
  • perl(strict)
  • perl(warnings)
  • perl-libs
  • rpmlib(CompressedFileNames) <= 3.0.4-1
  • rpmlib(FileDigests) <= 4.6.0-1
  • rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  • rpmlib(PayloadIsZstd) <= 5.4.18-1
  • rtld(GNU_HASH)
Provides14
  • perl(Net::DNS::SEC) = 1.27
  • perl(Net::DNS::SEC::DSA) = 2042
  • perl(Net::DNS::SEC::Digest) = 2002
  • perl(Net::DNS::SEC::Digest::MD5)
  • perl(Net::DNS::SEC::Digest::SHA)
  • perl(Net::DNS::SEC::Digest::SHA3)
  • perl(Net::DNS::SEC::Digest::SM3)
  • perl(Net::DNS::SEC::ECDSA) = 2002
  • perl(Net::DNS::SEC::EdDSA) = 2002
  • perl(Net::DNS::SEC::Keyset) = 2002
  • perl(Net::DNS::SEC::Private) = 2003
  • perl(Net::DNS::SEC::RSA) = 2042
  • perl-Net-DNS-SEC = 1.27-4.fc45
  • perl-Net-DNS-SEC(riscv-64) = 1.27-4.fc45
ObsoletesNo Obsoletes
ConflictsNo Conflicts
RecommendsNo Recommends
SuggestsNo Suggests
SupplementsNo Supplements
EnhancesNo Enhances

Files

38
Name ascending sort Size
/usr/lib/.build-id 0.00 B
/usr/lib/.build-id/dc 0.00 B
/usr/lib/.build-id/dc/13fc13178597e2e4b7ba771a70fbf1ebfb324f 63.00 B
/usr/lib64/perl5/vendor_perl/Net 0.00 B
/usr/lib64/perl5/vendor_perl/Net/DNS 0.00 B
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC 0.00 B
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC.pm 3.44 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/DSA.pm 4.24 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/Digest.pm 4.07 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/ECDSA.pm 4.07 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/EdDSA.pm 3.67 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/Keyset.pm 8.91 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/Private.pm 5.12 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/RSA.pm 3.92 KB
/usr/lib64/perl5/vendor_perl/Net/DNS/SEC/libcrypto.pod 1.50 KB
/usr/lib64/perl5/vendor_perl/auto/Net 0.00 B
/usr/lib64/perl5/vendor_perl/auto/Net/DNS 0.00 B
/usr/lib64/perl5/vendor_perl/auto/Net/DNS/SEC 0.00 B
/usr/lib64/perl5/vendor_perl/auto/Net/DNS/SEC/SEC.so 26.95 KB
/usr/share/doc/perl-Net-DNS-SEC 0.00 B
/usr/share/doc/perl-Net-DNS-SEC/Changes 19.84 KB
/usr/share/doc/perl-Net-DNS-SEC/README 5.10 KB
/usr/share/doc/perl-Net-DNS-SEC/WARNING 556.00 B
/usr/share/doc/perl-Net-DNS-SEC/demo 0.00 B
/usr/share/doc/perl-Net-DNS-SEC/demo/getkeyset 2.09 KB
/usr/share/doc/perl-Net-DNS-SEC/demo/key2ds 1.73 KB
/usr/share/doc/perl-Net-DNS-SEC/demo/make-signed-keyset 3.61 KB
/usr/share/licenses/perl-Net-DNS-SEC 0.00 B
/usr/share/licenses/perl-Net-DNS-SEC/LICENSE 991.00 B
/usr/share/man/man3/Net::DNS::SEC.3pm.gz 2.08 KB
/usr/share/man/man3/Net::DNS::SEC::DSA.3pm.gz 1.82 KB
/usr/share/man/man3/Net::DNS::SEC::Digest.3pm.gz 1.87 KB
/usr/share/man/man3/Net::DNS::SEC::ECDSA.3pm.gz 1.84 KB
/usr/share/man/man3/Net::DNS::SEC::EdDSA.3pm.gz 1.84 KB
/usr/share/man/man3/Net::DNS::SEC::Keyset.3pm.gz 2.89 KB
/usr/share/man/man3/Net::DNS::SEC::Private.3pm.gz 2.32 KB
/usr/share/man/man3/Net::DNS::SEC::RSA.3pm.gz 1.83 KB
/usr/share/man/man3/Net::DNS::SEC::libcrypto.3pm.gz 1.61 KB
Files 1–38 of 38

Component of

buildroots that installed this RPM

No Buildroots