Thu, 12 Nov 2026 04:04:56 UTC Log in
A full featured C++ MIME library 130.54 KB built 2026-10-15 04:40:03 GMT

Description

mimetic is an Email library (MIME) written in C++ designed to be easy to use and integrate but yet fast and efficient. It has been built around the standard lib. This means that you'll not find yet another string class or list implementation and that you'll feel comfortable in using this library from the very first time. Most classes functionalities and behavior will be clear if you ever studied MIME and its components; if you don't know anything about Internet messages you'll probably want to read some RFCs to understand the topic and, therefore, easily use the library whose names, whenever possible, overlap terms adopted in the standard RFC documents. At the very least: RFC 822, RFC 2045 and RFC 2046.

Dependencies

28 total
Requires25
  • ld-linux-riscv64-lp64d.so.1()(64bit)
  • ld-linux-riscv64-lp64d.so.1(GLIBC_2.27)(64bit)
  • libc.so.6()(64bit)
  • libc.so.6(GLIBC_2.27)(64bit)
  • libc.so.6(GLIBC_2.33)(64bit)
  • libc.so.6(GLIBC_2.38)(64bit)
  • libgcc_s.so.1()(64bit)
  • libgcc_s.so.1(GCC_3.0)(64bit)
  • libm.so.6()(64bit)
  • libstdc++.so.6()(64bit)
  • libstdc++.so.6(CXXABI_1.3)(64bit)
  • libstdc++.so.6(CXXABI_1.3.9)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.30)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.32)(64bit)
  • libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
  • rpmlib(CompressedFileNames) <= 3.0.4-1
  • rpmlib(FileDigests) <= 4.6.0-1
  • rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  • rpmlib(PayloadIsZstd) <= 5.4.18-1
  • rtld(GNU_HASH)
Provides3
  • libmimetic.so.0()(64bit)
  • mimetic = 0.9.8-29.fc45
  • mimetic(riscv-64) = 0.9.8-29.fc45
ObsoletesNo Obsoletes
ConflictsNo Conflicts
RecommendsNo Recommends
SuggestsNo Suggests
SupplementsNo Supplements
EnhancesNo Enhances

Files

12
Files 1–12 of 12

Component of

buildroots that installed this RPM

No Buildroots