Thu, 29 Oct 2026 06:21:25 UTC | login

Information for RPM python3-pyftpdlib-2.2.0-3.fc45.noarch.rpm

ID77040
Buildpython-pyftpdlib-2.2.0-3.fc45
Namepython3-pyftpdlib
Version2.2.0
Release3.fc45
Epoch
Archnoarch
DraftFalse
SummaryVery fast asynchronous FTP server library
DescriptionPython FTP server library provides a high-level portable interface to easily write very efficient, scalable and asynchronous FTP servers with Python. It is the most complete RFC-959 FTP server implementation available for Python programming language. ** Features ** - Extremely lightweight, fast and scalable - Uses sendfile(2) system call for uploads - Uses epoll() / kqueue() / select() to handle concurrency asynchronously - Can optionally skip to a multiple thread / process model (as in: you’ll be free to block or use slow filesystems) - Portable: entirely written in pure Python; works with Python 2.7 and 3.x using a single code base - Supports FTPS (RFC-4217), IPv6 (RFC-2428), Unicode file names (RFC-2640), MLSD/MLST commands (RFC-3659) - Support for virtual users and virtual filesystem - Flexible system of "authorizers" able to manage both "virtual" and "real" users on both UNIX and Windows ** Performance ** Despite being written in an interpreted language, pyftpdlib has transfer rates comparable or superior to common UNIX FTP servers written in C. It usually tends to scale better because whereas vsftpd and proftpd use multiple processes to achieve concurrency, pyftpdlib only uses one.
Build Time2026-10-17 12:17:11 GMT
Size194.65 KB
cbbd716743b9dd73de00e82a4c766f85
LicenseMIT
Buildrootf45-build-32301-658
Provides
ftpbench = 2.2.0-3.fc45
python-pyftpdlib = 2.2.0-3.fc45
python3-pyftpdlib = 2.2.0-3.fc45
python3.15-pyftpdlib = 2.2.0-3.fc45
python3.15dist(pyftpdlib) = 2.2
python3dist(pyftpdlib) = 2.2
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
/usr/bin/python3
python(abi) = 3.15
python3.15dist(pyasynchat)
python3.15dist(pyasyncore)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
Recommends
python3dist(pyftpdlib[ssl])
Suggests
python3dist(psutil)
Supplements No Supplements
Enhances No Enhances
Files
Page:
1 through 50 of 80 >>>
Name ascending sort Size
/usr/bin/ftpbench17.19 KB
/usr/lib/python3.15/site-packages/pyftpdlib0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info/INSTALLER4.00 B
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info/METADATA12.29 KB
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info/WHEEL91.00 B
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info/licenses0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info/licenses/LICENSE1.05 KB
/usr/lib/python3.15/site-packages/pyftpdlib-2.2.0.dist-info/top_level.txt10.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/__init__.py2.78 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__main__.py12.19 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/__init__.cpython-315.opt-1.pyc2.81 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/__init__.cpython-315.pyc2.81 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/__main__.cpython-315.opt-1.pyc14.47 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/__main__.cpython-315.pyc14.47 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/authorizers.cpython-315.opt-1.pyc37.08 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/authorizers.cpython-315.pyc37.08 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/exceptions.cpython-315.opt-1.pyc1.81 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/exceptions.cpython-315.pyc1.81 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/filesystems.cpython-315.opt-1.pyc23.12 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/filesystems.cpython-315.pyc23.12 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/ioloop.cpython-315.opt-1.pyc45.36 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/ioloop.cpython-315.pyc46.14 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/log.cpython-315.opt-1.pyc6.34 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/log.cpython-315.pyc6.34 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/prefork.cpython-315.opt-1.pyc4.25 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/prefork.cpython-315.pyc4.28 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/servers.cpython-315.opt-1.pyc25.12 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/servers.cpython-315.pyc25.12 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/utils.cpython-315.opt-1.pyc4.05 KB
/usr/lib/python3.15/site-packages/pyftpdlib/__pycache__/utils.cpython-315.pyc4.38 KB
/usr/lib/python3.15/site-packages/pyftpdlib/authorizers.py33.71 KB
/usr/lib/python3.15/site-packages/pyftpdlib/exceptions.py1.03 KB
/usr/lib/python3.15/site-packages/pyftpdlib/filesystems.py20.85 KB
/usr/lib/python3.15/site-packages/pyftpdlib/handlers0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/__init__.py507.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/__pycache__0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/__pycache__/__init__.cpython-315.opt-1.pyc525.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/__pycache__/__init__.cpython-315.pyc525.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__init__.py155.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__0.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/__init__.cpython-315.opt-1.pyc169.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/__init__.cpython-315.pyc169.00 B
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/control.cpython-315.opt-1.pyc92.86 KB
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/control.cpython-315.pyc93.03 KB
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/data.cpython-315.opt-1.pyc22.25 KB
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/data.cpython-315.pyc22.25 KB
/usr/lib/python3.15/site-packages/pyftpdlib/handlers/ftp/__pycache__/dispatchers.cpython-315.opt-1.pyc14.27 KB
Component of
1 through 2 of 2
Buildroot descending sort Created State
f45-build-32816-662 2026-10-17 13:17:44 expired
f45-build-32580-660 2026-10-17 12:46:48 expired