Thu, 29 Oct 2026 05:19:35 UTC | login

Information for RPM python-pyftpdlib-2.2.0-3.fc45.src.rpm

ID77037
Buildpython-pyftpdlib-2.2.0-3.fc45
Namepython-pyftpdlib
Version2.2.0
Release3.fc45
Epoch
Archsrc
DraftFalse
SummaryVery fast asynchronous FTP server library
DescriptionPython FTP server library provides a high-level portable interface to easily write very efficient, scalable and asynchronous FTP servers with Python. It is the most complete RFC-959 FTP server implementation available for Python programming language. ** Features ** - Extremely lightweight, fast and scalable - Uses sendfile(2) system call for uploads - Uses epoll() / kqueue() / select() to handle concurrency asynchronously - Can optionally skip to a multiple thread / process model (as in: you’ll be free to block or use slow filesystems) - Portable: entirely written in pure Python; works with Python 2.7 and 3.x using a single code base - Supports FTPS (RFC-4217), IPv6 (RFC-2428), Unicode file names (RFC-2640), MLSD/MLST commands (RFC-3659) - Support for virtual users and virtual filesystem - Flexible system of "authorizers" able to manage both "virtual" and "real" users on both UNIX and Windows ** Performance ** Despite being written in an interpreted language, pyftpdlib has transfer rates comparable or superior to common UNIX FTP servers written in C. It usually tends to scale better because whereas vsftpd and proftpd use multiple processes to achieve concurrency, pyftpdlib only uses one.
Build Time2026-10-17 12:17:11 GMT
Size329.19 KB
17b01f652f5c09670820958cdbc1cc67
LicenseMIT
Buildrootf45-build-32301-658
Provides
python3-pyftpdlib = 2.2.0-3.fc45
python3-pyftpdlib+ssl = 2.2.0-3.fc45
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
(python3dist(tomli) if python3-devel < 3.11)
help2man
pyproject-rpm-macros
python3-devel
python3dist(packaging)
python3dist(pip) >= 19
python3dist(psutil)
python3dist(pyasynchat)
python3dist(pyasyncore)
python3dist(pyopenssl)
python3dist(pytest)
python3dist(pytest-xdist)
python3dist(setuptools)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(DynamicBuildRequires) <= 4.15.0-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(RichDependencies) <= 4.12.0-1
tomcli
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 2 of 2
Name ascending sort Size
pyftpdlib-release-2.2.0.tar.gz296.91 KB
python-pyftpdlib.spec5.01 KB
Component of No Buildroots