Tue, 20 Oct 2026 18:19:10 UTC | login

Information for RPM hash-slinger-3.6-2.fc45.noarch.rpm

ID37769
Buildhash-slinger-3.6-2.fc45
Namehash-slinger
Version3.6
Release2.fc45
Epoch
Archnoarch
DraftFalse
SummaryGenerate and verify various DNS records such as SSHFP, TLSA and OPENPGPKEY
DescriptionThis package contains various tools to generate special DNS records: sshfp Generate RFC-4255 SSHFP DNS records from known_hosts files or ssh-keyscan tlsa Generate RFC-6698 TLSA DNS records via TLS openpgpkey Generate RFC-7929 DNS records from OpenPGP keyrings ipseckey Generate RFC-4025 IPSECKEY DNS records on Libreswan IPsec servers This package has incorporated the old 'sshfp' and 'swede' commands/packages
Build Time2026-10-14 11:06:58 GMT
Size42.19 KB
743ba759445ba230e3eb104b82e5f543
LicenseGPL-2.0-or-later
Buildrootf45-build-13398-449
Provides
hash-slinger = 3.6-2.fc45
sshfp = 3.6
Obsoletes
sshfp < 2.0
Conflicts No Conflicts
Requires
/usr/bin/python3
openssh-clients >= 4
python3 >= 3.13
python3-cryptography
python3-dns
python3-gnupg >= 0.3.7
python3-unbound
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 14 of 14
Name ascending sort Size
/usr/bin/ipseckey1.93 KB
/usr/bin/openpgpkey9.46 KB
/usr/bin/sshfp13.13 KB
/usr/bin/tlsa36.44 KB
/usr/share/doc/hash-slinger0.00 B
/usr/share/doc/hash-slinger/BUGS6.00 B
/usr/share/doc/hash-slinger/CHANGES3.91 KB
/usr/share/doc/hash-slinger/README1.02 KB
/usr/share/licenses/hash-slinger0.00 B
/usr/share/licenses/hash-slinger/COPYING17.67 KB
/usr/share/man/man1/ipseckey.1.gz1.47 KB
/usr/share/man/man1/openpgpkey.1.gz1.65 KB
/usr/share/man/man1/sshfp.1.gz2.44 KB
/usr/share/man/man1/tlsa.1.gz2.30 KB
Component of No Buildroots