Sun, 08 Nov 2026 11:15:03 UTC Log in
MIME types module for Perl built by guoguo completed Fri, 16 Oct 2026 21:42:45 UTC

Description

MIME types are used in many applications, for instance as part of e-mail and HTTP traffic, to indicate the type of content that is transmitted. Sometimes detailed knowledge about a mime-type is need; however, this module only knows about the file-name extensions that relate to some file-type. It can also be used to produce the right format: types that are not registered at IANA need to use 'x-' prefixes.

RPMs

3 files, 2 arches
src
  • perl-MIME-Types-2.30-3.fc45.src.rpm 101.15 KB info · download
noarch
  • perl-MIME-Types-2.30-3.fc45.noarch.rpm 73.06 KB info · download
  • perl-MojoX-MIME-Types-2.30-3.fc45.noarch.rpm 16.23 KB info · download

Logs

noarch

Changelog

* Thu Jul 16 2026 Fedora Release Engineering <releng@fedoraproject.org> - 2.30-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_45_Mass_Rebuild

* Sat Jan 17 2026 Fedora Release Engineering <releng@fedoraproject.org> - 2.30-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_44_Mass_Rebuild

* Mon Dec 08 2025 Paul Howarth <paul@city-fan.org> - 2.30-1
- Update to 2.30
  Fixes:
  - No undef when simplifying illegal type (GH#15)
  Improvements:
  - Add bugtracker to meta
  - Better OO use of attributes

* Mon Sep 15 2025 Paul Howarth <paul@city-fan.org> - 2.29-1
- Update to 2.29
  - Require 5.16 (2012)
  - Remove xt/98perl.t
  - ::Type->defaultCharset()
  - Remove use of bareword filehandle
  - IANA updates

* Fri Jul 25 2025 Fedora Release Engineering <releng@fedoraproject.org> - 2.28-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_43_Mass_Rebuild

* Sat Apr 19 2025 Paul Howarth <paul@city-fan.org> - 2.28-1
- Update to 2.28
  Fixes:
  - Some 'deprecated' texts made it to types.db
  Improvements:
  - text/ecmascript RFC9239
  - Default charsets according to RFC6657
  - Update reference to specs RFC6838 and RFC9694
  - IANA updates
- Use %{make_build} and %{make_install}

* Fri Feb 07 2025 Paul Howarth <paul@city-fan.org> - 2.27-1
- Update to 2.27
  - IANA updates
  - Explicitly set $/ before reading the file by line

* Sat Jan 18 2025 Fedora Release Engineering <releng@fedoraproject.org> - 2.26-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.26-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild